To import an existing HM2 database to your current HM3 database, or to a new HM3 Database, you need to first make sure the database you want to import to is active.  If you want to import to a new database use the File > New Database ... (Ctrl+N) menu.  To import to an existing database set the database as active via the File > Open Database... (Ctrl+O) menu.

Next you need to open the File > Import HM2 Database... menu.

This will open the following Import HM2 Database window.

 
  1. Use the Import from: drop-down menu to choose the HM2 database you want to import.
  2. Select the [x] Hero only hands option if you only want to import hand history files that contain known/hero hole cards.
  3. You can use the Date range: filters if you only want to import a date specific sub-set of hands from the HM2 database to HM3.
  4. Select the Import button to import the database, or the Cancel button if you no longer want to import the HM2 database hands to HM3.

After selecting Import from step 4 above HM3 will export the hands from the HM2 database to a Temp folder so that HM3 can then import the hands.  The bottom status bar of HM3 will show the progress as it imports hands then runs tournament detection if the database contained tournaments.  


Once all database import processes are complete you can review your reports or use the database for live play with the HUD.

*If you have any problems importing a HM2 database to HM3:

Please try to create a new database: File > New Database then manually import some hands File > Import Folder > from C:\HM2Archive and/or C:\HM3Archive

If the new database works:  Can you please backup your HM2 database/settings as explained here then upload the backup file to filedropper.com and send us the download link in a support ticket so we can test your database import issues.


 
Sometimes you may need to create a new database. This can be done to look at different data or to test an issue. This will not erase data from your prior database and you can switch back to it at any time.  The default location for HM3 databases is C:\Users\[UserName]\Documents\Holdem Manager 3\Databases.  If you can't see it turn off the windows option that is hiding that directory.
 
  1. File > New Database... (Ctrl+N).
  2. Choose a folder for the database if you want it to be in a different location than the default database location.
  3. Enter a name for the database in the File Name: field
  4. Click Open.
  5. File > Import Files... (Ctrl+I) or Import Folder... (Ctrl+F).
  6. Select the Files or Folder you want to import* then click the Select Folder button in the lower right corner of the Select Folder menu.
  7. The hands will first import, then tournament detection will run on any tournaments in the hands.  You can see the status of the import/detection on the bottom status bar of the software.  Once all the hands are imported/detected you can review all of the data in the Reports.

*All original hands that are auto-imported get moved to an archive for performance reasons. Your \HM2Archive is in C:\HM2Archive by default, but you may have put it anywhere. You can verify the path in the HM2 > Site Setup > Auto Import Folders menu.  Your \HM3Archive is in C:\HM3Archive by default, but you may have put it anywhere. The path can be verified in the HM3 > Tools > Settings > Import menu.